Export your diagrams and tables into high-quality image files for reports, presentations!

1. Exporting via the Graphical Interface

The easiest way to export diagrams is directly through the Astah workspace.

  1. Navigate to [File] → [Export Image]
  2. Select your scope:
    • Current Diagram: Exports only the diagram currently active in your editor.
    • Multi Diagrams: Opens a selection window where you can batch-select diagrams and tables.
      Export Image

  3. Choose your destination folder. Astah will automatically use the Diagram Name as the filename.

TIPS: To adjust the default resolution (DPI) or background transparency, go to [Tools] → [System Properties] → [Image Export].
System Properties - Image Export


2. Command-Line Export

You can also export images directly via command-line.

Basic Command Syntax

Use the -image option followed by the diagram type and source file.

Available Format

PNG, JPEG, EMF or SVG. By default, images are exported in PNG format unless specified otherwise.

If you are using Astah SysML:

[Windows] Export all the diagrams of the C:\input\ABC.axmz .file to C:\output in PNG

astahsyml-command.bat -image all -f C:\input\ABC.axmz -o C:\output

[macOS] Export all the diagrams of ~/input/ABC.axmz file to ~/output in JPEG

astahsysml-command.sh -image all -f ~/input/ABC.axmz -o ~/output -t jpg

If you are using Astah System Safety:

[Windows] Export all the diagrams of the C:\input\ABC.axmz .file to C:\output in PNG

astahsystemsafety-command.bat -image all -f C:\input\ABC.axmz -o C:\output

[macOS] Export all the diagrams of ~/input/ABC.axmz file to ~/output in JPEG

astahsystemsafety-command.sh -image all -f ~/input/ABC.axmz -o ~/output -t jpg

Reference: Diagram Type Options

Instead of all, you can specify specific types:

SysML

Option
Diagram Type
reqRequirement Diagram
rqtRequirement Table
bddBlock Definition Diagram
ibdInternal Block Diagram
parParametric Diagram
ucUseCase Diagram
actActivity Diagram
stmStatemachine Diagram
sdSequence Diagram

STAMP/STPA

Option
Diagram Type
ptPrecondition Table
ahsctAccident Hazard Safety Constraint Table
csdControl Structure Diagram
ucatUCA Table
cldControl Loop Diagram
lstLoss Scenario Table
ctCountermeasure Table

Others

Option
Diagram Type
allAll diagrams/tables
scdSafety Concept Diagram
gsnGSN/D-Case
mmMind Map

Advanced CLI Parameters

OptionDescriptionKindNote
-dpi,–dpi [image dpi]Resolution (dpi)–Specify the dpi of image
Default is 96 in the System Properties ([Tools] – [System Properties] – [Image Export].
-f,–file [target file]Target file
-id,–dgm_id [ids for target diagrams]Set IDSpecify Diagram’s IDs with a space between them. If you specify the ID, file names will be the ID instead of diagram names.
-o,–output [output]Base folder where this image is exported toFolder where the image is exported to is “base folder and project file name.
-t,–type [image type]Format of imagespng, jpg, svg, emfPNG, JPEG, SVG, EMF(Enhanced Metafile)
If you do not specify the image format, it’ll be exported to .png files.